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USE IN LIFE SUPPORT DEVICES OR SYSTEMS MUST BE EXPRESSLY AUTHORIZED.
STMicroelectronics PRODUCTS ARE NOT AUTHORIZED FOR USE AS CRITICAL COMPONENTS IN
LIFE SUPPORT DEVICES OR SYSTEMS WITHOUT THE EXPRESS WRITTEN APPROVAL OF
STMicroelectronics. As used herein:

1. Life support devices or systems are those
which (a) are intended for surgical implant into
the body, or (b) support or sustain life, and whose
failure to perform, when properly used in
accordance with instructions for use provided
with the product, can be reasonably expected to
result in significant injury to the user.

2. A critical component is any component of a life
support device or system whose failure to
perform can reasonably be expected to cause the
failure of the life support device or system, or to
affect its safety or effectiveness. 

INSTRUCTIONS FOR USE—WARNING

This product is conform to the 89/336/EEC Directive. It complies with the ITE EN55022 standard for
EMC emissions and generic 50082-1 (1992 edition) immunity standards.

This product is an FCC Class-A apparatus. In a residential environment, it may cause
radioelectrical disturbances.

In addition, some parts of this emulator are not contained in an outer casing; consequently, it cannot be
immune against electrostatic discharges (ESD). It should therefore be handled only in static safe
working areas. Please refer to Appendix A: EMC Conformity and Safety Requirements on page 57 for
relevant safety information.



Table of Contents

3/71

Chapter 1: Introduction  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 5

1.1 Emulator configuration .................................................................................. 6

1.2 Emulator operation ....................................................................................... 7

1.3 Software and documentation for the emulator kit ......................................... 8

1.4 About this manual.... ..................................................................................... 8

1.5 Getting assistance ........................................................................................ 9

Chapter 2: Getting Started . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 11

2.1 Your system requirements .......................................................................... 11

2.2 Delivery checklist ........................................................................................ 11

2.3 Installing the hardware ................................................................................ 13

2.4 Debuggers supporting the ST7 HDS2 emulator ......................................... 19

Chapter 3: STVD7  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 21

3.1 Installing STVD7 ......................................................................................... 21

3.2 Launching STVD7 ....................................................................................... 22

3.3 About STVD7 debugging features .............................................................. 23

3.4 Workspaces ................................................................................................ 24

3.5 Toolchains and application files .................................................................. 25

3.6 Creating a workspace ................................................................................. 28

3.7 Opening an existing workspace .................................................................. 30

3.8 Opening files directly for debugging (*.abs, *.s19, *.hex  and *.elf ) ........... 33

3.9 Opening lone programmable files (*.s19 or *.hex) ...................................... 34

3.10 Changing your project settings ................................................................... 35

3.11 Saving workspaces ..................................................................................... 37

3.12 Debug context and Build context ................................................................ 39

3.13 Configuring the MCU .................................................................................. 40

3.14 Start debugging! ......................................................................................... 45

Chapter 4: Emulator Features  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 47

4.1 Main features of the ST7 HDS2 emulator series ........................................ 47

4.2 Specific features ......................................................................................... 47

4.3 Emulator architecture .................................................................................. 48

4.4 Output triggers ............................................................................................ 51

4.5 Analyser probe input signals ....................................................................... 53

4.6 Front panel LEDs ........................................................................................ 54

4.7 On-chip peripherals .................................................................................... 55



Table of Contents

4/71

4.8 Emulation functional limitations and discrepancies .................................... 55

Appendix A: EMC Conformity and Safety Requirements . . . . . . . . . . . . . . . . 57

Appendix B: Troubleshooting . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59

B.1 Identifying the problem ............................................................................... 59

B.2 Changing the parallel port setup on your PC .............................................. 59

B.3 Running the hardware test .......................................................................... 60

Appendix C: Glossary  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63

Product Support  . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65

Getting prepared before you call...............................................................................  65

Contact list ................................................................................................................  65

Software updates ......................................................................................................  66

Hardware spare parts ...............................................................................................  66

Index . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 69



ST7MDTU5-EMU2B User Manual 1 - Introduction

5/71

1 INTRODUCTION

Thanks for choosing ST7! This manual will help you get started with the
ST7MDTU5-EMU2B emulator kit.

The ST7MDTU5-EMU2B emulator allows you to control the execution of programs
that you have written for the ST7265x family of MCUs (see list below) and assists
you in debugging your application hardware as well as your software. The
ST7MDTU5-EMU2B kit comes with the debugger software package—ST7 Visual
Debug—which contains all of the necessary resources to help you design, develop
and debug ST7 application software running in a real environment.

Note: If you come across any terms or abbreviations you do not understand, you can check their
meaning in the Glossary on page 63.

First off, check that the ST7 MCU that you have picked for your application is in the
list of devices supported by this version of the ST7MDTU5-EMU2B emulator:

The Emulator Package is made up of two main parts:

• The Hardware Development System (ST7 HDS2), which is the common
mainframe to all ST7 emulators.

• The ST7MDTU5-Active Probe, dedicated to the family, which constitutes the
physical link between the emulator and your application.

Note: When receiving the ST7MDTU5-EMU2B development tool, please refer to the Delivery
checklist on page 11 to confirm that all of the contents of the package are present.

The emulator performs two main functions:

• It replaces the microcontroller in the application, by means of an emulation
probe that is plugged into the application in place of the emulated MCU.

• It controls the internal data bus of the emulated microcontroller, providing
arbitration and tracing capabilities on all accesses to any of the following
resources:

Supported Devices

ST72651

ST72F651

ST72652

ST72F652

1



1 - Introduction ST7MDTU5-EMU2B User Manual

6/71

- ST7 HDS2 resources,

- ST7MDTU5-Active Probe resources,

- Application resources.

Therefore, you can have the emulator running your software in the application just
as the emulated MCU would do, and have extensive tracing and control
capabilities (i.e. keeping track of what the MCU does, and making it react in a
specific way upon defined conditions).

In this way, it is possible to fully emulate microcontroller resources.

Please refer to Section 4.8: Emulation functional limitations and discrepancies on page 55
for a description of the limitations on the current release of this emulator kit.

1.1 Emulator configuration

Figure 1 shows the configuration for the ST7MDTU5-EMU2B emulator kit. The
main ST7 HDS2 box is connected to your PC via the parallel port. Two flat cables
connect the ST7 HDS2 box to the ST7MDTU5-Active Probe. The ST7 Generic

Figure 1: ST7MDTU5-EMU2B general configuration
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Probe is connected to the ST7MDTU5-TEB, to which a device adapter can be fixed
so that you can connect the emulator to your application board.

The emulator is operated from your host PC using STVD7, a state-of-the-art,
integrated development environment, from which you can configure and control
the emulator, debug, edit and rebuild your application program.

1.2 Emulator operation

The emulator is controlled using STVD7, (also referred to as ST7 Visual Debug).
STVD7 integrates all phases of an application development in a single, powerful
and easy to use environment. 

The graphical interface is composed of one main window which consists of an
integrated set of windows, menus, toolbars and other elements that allow the user
to create, build, debug and refine an application using a single tool. The visual
environment can be personalized; the user can change the position of all windows,
open or close individual elements, alter which windows are visible at startup, and
save the configuration. User-defined toolbars may be created, and command icons
added or removed from toolbars. The integrated syntax-color highlighting editor
allows several source files to be edited in a single place. 

Thanks to the powerful features of the debugger, the debugging and tuning of an
application is made easier and quicker. Debugging with STVD7 (with an
ST7 HDS2 emulator) involves the following functional aspects: 

• Loading the application. 

• Defining the memory map and option configuration of the target MCU. 

• Running the application. 

• Viewing source and disassembled code. 

• Setting instruction breakpoints. 

• Setting data breakpoints. 

• Using the Logical Analyser to impose counters and conditions on breakpoints
and trace recording.

• Viewing variables, memory and registers. 

• Viewing history of execution: trace (up to 1024 records) and call stack features. 

Chapter 3:  STVD7 on page 21, explains how to install ST7 Visual Debug on your
PC, and set up the emulator configuration so that you can begin your debugging
session. 

When your application is fully debugged, the ST7 EPROM programming board
(ref.: ST7MDTU5-EPB — not provided with this emulator kit) can be used to
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program the emulation device with the Motorola S Record format file produced by
the OBSEND formatter.

1.3 Software and documentation for the emulator kit

The “MCU on CD” CD-ROM contains:

• ST7 Tools, comprising the following software:

- The source-level graphic debugger, STVD7, that operates with ST7-HDS2
Emulators, other hardware targets or as a standalone ST7 simulator.

- The ST7 Assembler toolchain, composed of an assembler, linker, librarian
and formatter.

- The ST7 Windows Epromer to program your MCU target devices.

• Third-party C compiler and toolchain demos (Hiware and Cosmic).

• ST7 Assembler-Linker User Manual and the ST7 Programming Manual
(available in Adobe Acrobat PDF format).

• STVD7 User Manual (available in Adobe Acrobat PDF).

• ST7 application notes (with sources), training slides and exercises, this manual
(in PDF version), and other useful reference materials.

• Datasheets for ST7 MCUs are available individually in Adobe Acrobat PDF
format.

1.4 About this manual....

Detailed instructions on how to install your emulator configuration are described in
Chapter 2:  Getting Started on page 11.

How to start debugging your application using your emulator and ST7 Visual
Debug is described in Chapter 3:  STVD7 on page 21.

The emulator kit’s hardware features are described in Chapter 4:  Emulator
Features on page 43.

The following conventions are used in this manual:

Bold text highlights key terms, phrases and is used when referring to names of
dialog boxes, windows and tabs within windows.

Bold italic text denotes menu commands (or sequence of commands), options,
buttons or checkboxes which you must click in order to perform an action. 

Italicized text highlights document names, variable strings, column names and field
names.
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Code font designates file names, programming commands, path names and any
text you must type.

The > symbol is used in a sequence of commands to mean “then”. For example, to
open an application in Windows, we would write: “Click Start>Programs>ST7
Tool Chain>....”.

1.5 Getting assistance

For more information, application notes, FAQs and software updates on all the ST
microcontroller families, check out the CD-ROM or our website:

http://mcu.st.com

For assistance on all ST microcontroller subjects, or if you need help with using
your emulator, use the contact list provided in Contact list on page 65. We’ll be
glad to help you!
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2 GETTING STARTED

2.1 Your system requirements

The ST7MDTU5-EMU2B HDS2 Emulator (both hardware and software
components) has been designed to work with PCs meeting the following
requirements:

• One of the following operating systems: Microsoft® Windows® 95, 98, 2000 or

NT®.

• Intel® Pentium (or compatible) processor with minimum speed of 133 MHz.

• Minimum RAM of 32 MB (64 MB recommended).

• 50 MB of free hard disk space to install all of the ST7 tools.

2.2 Delivery checklist

The emulator kit (ref.: ST7MDTU5-EMU2B), is delivered with the following (refer to
Figure 2):

1 One emulator box containing the ST7 HDS2 main board (ref.: MB176) and two
50-wire flat cables to connect the ST7 HDS2 main board to the generic
emulation probe.

2 One emulator power supply.

3 One parallel cable.

4 Two SMB to BNC trigger cables.

5 One analyser probe cable.

6 A TQFP64 (14 x 14) device adapter (ref.: DB474A) and TET socket
(ref.: TET 064SA).

7 One generic emulation probe—the ST7 Generic Probe (ref.: DB467).

8 An ST7MDTU5-Target Emulation Board (TEB) (ref.: DB473).

9 Three EMC ferrite clips.

10 A TQFP64-0.8 (10 x 10) socket (ref.: TET 064SA) and cover, for soldering to
your application board.

11 A 20 cm TQFP64 (10 x 10) flex cable (ref.: DB520) with two 40-pin connectors,
for connection between the emulation probe and your application board. Used
with (10).

2
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12 The following documentation and software (not shown):

- This manual.

- A CD-ROM containing ST7 software and documentation, including ST7

Visual Debug, the ST7 Assembler Toolchain and a Windows® Epromer.

(1) (2)

(3) (4)

(5) (6)

(7) (8)

Figure 2: Main components of ST7MDTU5-EMU2B emulator kit
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2.3 Installing the hardware

The ST7 HDS2 emulator is connected through the parallel port to a PC
computer which runs the control software (ST7 Visual Debug) as explained
later. To connect your ST7 HDS2 emulator, you will have to follow these general
steps (explained in detail later):

1 Connect the ST7 HDS2 emulator to your PC using the parallel cable
provided.

2 Connect the two flat cables of your ST7 HDS2 emulator to the emulation
probe connectors.

3 Connect the probe to the application board using device adapters or flex
cable.

4 Connect the power supply cable between the power supply block and the
power connector located on the rear panel of your ST7 HDS2 emulator. 

5 Power up the emulator and then connect your application power supply.

(9) (10)

(11)

Figure 2: Main components of ST7MDTU5-EMU2B emulator kit
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A connection flow diagram is shown in Figure 3. Each installation step is described
in detail in the following sections.

2.3.1 Step 1: Connecting the emulator to your PC

1 Shutdown and power-off the PC that is to be connected to the emulator. 

2 Connect one end of the parallel cable to the emulator’s rear panel 25-pin SUB-
D connector and the other end to one of the PC’s parallel ports (LPT1 to
LPT2)—refer to Figure 4.

Figure 3: ST7MDTU5-EMU2B connection flow

ST7MDTU5-TEB

1

2

3
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5

Application Board Power Supply
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ST7 Generic Probe
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Note: Be sure to use the parallel cable provided with the emulator—using a longer parallel cable
may cause emulator malfunctions.

2.3.2 Step 2: Connecting the emulator to the probe

1 Ensure that the application and the emulator are powered-off.

2 Plug the two 50-wire flat cables into the J1 and J2 connections on the probe, as

described below (refer also to Figure 5):

EMC-compliant probes: In order to work under an EMC-compliant environment,
clip the three EMC ferrites onto the 50-wire flat cables linking the probe to the

Figure 4: Connecting the emulator to the PC

ST7-HDS2 Emulator (ref.: MB176) ST7 Generic Probe (ref.: DB467)

Upper cable

Lower cable

J2

J1

Figure 5: Connecting the emulator to the generic probe
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emulator box. Place these ferrites as close to the emulator window as possible.
Three ferrites are provided in the package. See Figure 6 for an illustration of where
to attach the ferrites.

Figure 6: Making your probes EMC-compliant

ST7 HDS2
Emulator
Side View

Ferrites

Flat Cables Side View

Probe + Application 
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2.3.3 Step 3:  Connecting the probe to your application board

If you are using the TQFP64 14x14 package, proceed as follows (see 
Figure 7):

For the TQFP64 14 x 14 package, you must assemble the ST7MDTU5-Active
Probe, which is made up of a generic ST7 emulation probe connected to a Target
Emulation Board, which is in turn connected to a TQFP64 (14 x 14) device
adapter.

1 Solder the TET socket base (ref.: TET 064SA) of the TQFP64 device adapter
onto your application board.

2 Place the TQFP64 device adapter (ref.: DB474A) upon the TET socket base,
aligning pin 1 of the device adapter with pin 1 on your application board’s
socket. (On the TQFP64 device adapter, pin 1 is indicated by a chamfer on the
adapter base.)

3 Once in place, screw the TQFP64 adapter and the TET socket base together.

4 Now connect the joined ST7 Generic Probe (ref.: DB467A) and ST7MDTU5-
TEB (ref.: DB473A) to the TQFP64 adapter, by inserting the female pins of the
adapter into the male connectors on the underside of the ST7MDTU5-TEB.

Note: You can use your emulator kit with ST7 Visual Debug without an application board—however
the emulation probes must be connected to the HDS2 emulator. 

Figure 7: TQFP64 (14x14) MCU package connections

J2J1

3

ST7 Generic Probe (ref.: DB467)

ST7MDTU5-TEB
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1

Application Board

TQFP64 device adapter
(ref.: DB474)
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2

4
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If you are using the TQFP64 10 x 10 package, proceed as follows (see 
Figure 8):

To connect the ST7MDTU5-Active Probe to your application board, a TQFP64 flex
cable and a TQFP64-0.8 socket base have been provided.

1 Solder the TQFP64-0.8 socket base (ref.: TET 064SA) onto your application
board. Do not use the socket cover (set it aside for future use with an actual
MCU).

2 Connect the ST7 Generic Probe (ref.: DB467) to the ST7MDTU5 TEB
(ref.: DB473).

3 Connect the two 40-pin connectors of the 20 cm TQFP64 flex cable
(ref.: DB520) to the two 40-pin connectors (labelled QFP64 FLEX ADAPTER)
on the underside of the ST7MDTU5 TEB (ref.: DB473), taking care to align
pin 1 on each flex cable connector with the pin 1 on each TEB connector.

4 Connect the TQFP64 flex cable end to the TQFP64 socket base, making sure
to align pin 1 on the TQFP64 flex connector with pin 1 on the socket base.
(Pin 1 is indicated by a chamfer on the TQFP64 flex connector and by a little
arrow or chamfer on the socket base.)

5 Now use the four screws supplied to fasten this entire assembly together
through the holes located on the TQFP64 flex cable connector as indicated in
Figure 8.

Figure 8: TQFP64 MCU package connections
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2.3.4 Step 4: Connecting the emulator power supply

Note: Make sure that both the ST7MDTU5-EMU2B and the application are OFF before making any
connections. 

1 Connect the external power supply provided with the emulator to the rear panel
of the mainframe using a 5-pin DIN connector. 

2 Plug the power supply into the mains using the supply cable provided.

2.3.5 Step 5: Powering up 

1 Check the ST7 HDS2 operating voltage (110 V/220 V) indicated on the label on
the power supply. Contact your dealer if this voltage does not correspond to
your mains’ power supply. 

2 Power up the ST7 HDS2 emulator from the ON/OFF switch located on the rear
panel. The LED labelled Power on the front panel should then light up. 

3 Power up your application.

2.4 Debuggers supporting the ST7 HDS2 emulator

STVD7 is the STMicroelectronics debugger currently supporting the ST7 HDS2
emulator. How to install and start using it is described in Chapter 3 on page 21.

STVD7 is a free software package, provided on the MCU on CD CD-ROM supplied
with your emulator. Regularly updated versions are also available from the
STMicroelectronics website (see the section entitled Software updates on page 66
for more information).

Third party debuggers supporting the ST7 HDS2 emulator include the following:

• ST7-Hiwave by HIWARE

• Zap by COSMIC

• Hitop by HITEX.

Mains Voltage Specifications

AC Voltage 100 V to 240 V

Frequency 50 Hz to 60 Hz
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3 STVD7

STVD7 is an integrated development environment that allows you to edit, debug
and rebuild your application all from within STVD7.

The following sections tell you:

• Section 3.1—how to install the STVD7 software,

• Section 3.2—how to launch STVD7,

• Section 3.3—a little about STVD7’s debugging features,

• Section 3.4—what a workspace is,

• Section 3.5—what toolchains and executable files are supported by STVD7,

• Section 3.6—how to create a STVD7 workspace,

• Section 3.7—how to open existing workspaces,

• Section 3.8—how to open binary files,

• Section 3.10—how to change your project settings,

• Section 3.11—how to save workspaces,

• Section 3.12—how to switch from the build context to the debug context,

• Section 3.13—how to configure the target MCU in order to debug more
accurately and efficiently.

3.1 Installing STVD7

Your emulator comes with the “MCU on CD” CD-ROM which contains a number of
ST7 software tools. These tools run under the Windows® 95, 98, 2000, Millenium
and Windows® NT® operating systems.

Note: To install the software on “MCU on CD”, Windows® 2000 and NT® users must have
administrator privileges.

To install and setup the ST7 software tools, follow these steps:

1 Close all other open applications on your Windows desktop.

2 Insert the “MCU on CD” into your CD-ROM drive. The CD-ROM’s autorun
feature will open up a welcome screen on your PC. If the autorun feature does

not work, use Windows® Explorer to browse to the CD-ROM’ s root folder, and
double-click on Welcome.exe.

3 Select Install Your Development Tools from the list of options. A new screen
will appear listing the different families of STMicroelectronics MCUs.

4 Use your mouse to place the cursor over the ST7 Tools option. Choose
ST Tools, then ST7 Toolchain from the lists that appear.

3
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5 The install wizard will be launched. Follow the instructions that appear on the
screen.

You can choose to install the complete toolchain (i.e. the appropriate version of
STVD7, STVP7 and the Assembler-Linker) for each type of development tool
(development kit, HDS2 or EMU3 emulators or simulator), or perform a
customized installation. 

If you choose a customized installation, you can choose to install any or all of
the STVD7 versions, and/or the Windows Epromer/STVP7 and/or the
Assembler-Linker. As a minimum, in order to emulate your application with
your emulator, you must install STVD7 for HDS2. 

If you also install the ST7 Assembly Toolchain, you will be able to use the ST7
Assembly Toolchain as part of STVD7’s integrated development environment.

The installation is now complete. You will be prompted to reboot your computer.
You should do so before launching STVD7.

3.2 Launching STVD7

1 From your Windows desktop, select Start>Programs>ST7 Tool
Chain>Development Tools>STVD7 HDS2 emulator.

2 The first time you open a version of STVD7 you will be prompted to enter the
toolchain paths to be used by STVD7’s integrated development environment. 

Figure 9: Toolchain Path dialog box
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Enter the paths for the toolchains that you use (i.e. any or all of the Hiware,
Cosmic or ST7 ASM toolchains) and click OK. (The default paths for each
toolchain are shown below.) 

3 If you choose Cancel, you will be prompted again to enter the toolchain paths
the next time you launch STVD7.

Note: You may modify the toolchain path at any time from within STVD7—simply select
Project>Toolchain Paths from the main menu to access the dialog box above.

3.3 About STVD7 debugging features

A number of advanced features are included in the STVD7 software:

• Data Breakpoints on the occurrence of a memory access via a read operation
or a write operation, or both.

• Instruction Breakpoints on the occurrence of an opcode fetch.

• A Logical Analyser that allows you to control either the recording of the trace
buffer, or a break in the execution of the application using a series of specific
conditions (events). 

• A Trace window to view the contents of the trace buffer, which permanently
records in real time on 32-bits:

- Address and data bus information.

- Flag status and 4 external signal values.

You can record up to 1024 executed cycles. Using trace filtering, you can filter
out only those cycles you wish to record in the trace buffer. You can equally
control which of the recorded cycles are displayed in the Trace window using
line filtering. Addresses, data, control/status bits and 4 user signals are
displayed using mnemonic and user symbols.

• Internal synchronization signals can be output to either of two Trigger Outlets
on the front panel of the emulator (OUT1 or OUT2). This feature enables you to
count events using an external equipment, when optimizing software for
example, or to synchronize an oscilloscope when debugging hardware. 

• Hardware Events can be used to control the sending of signals to the trigger
outputs. 

• You can choose the output that you wish the signal to be sent to (i.e. either
OUT1 or OUT2).

• A Hardware Test function that allows you to perform a number of hardware
tests on the Development Board, at your choosing. Refer to Running the



3 - STVD7 ST7MDTU5-EMU2B User Manual

24/71

Hardware Test for more information.

• A powerful online help facility can be invoked at any time to give additional
information about the commands, the processor or the emulator kit.

3.4 Workspaces

STVD7 organizes project development and debugging into workspaces.
Workspaces allow you to store application and project settings and save them, so
that each time you wish to work on the project, you will find all of the settings
exactly as you left them.

Creating a workspace is the first thing that you need to do when using STVD7 for
the first time or when starting any new project. You must have an open workspace
to work with STVD7. How to create a new workspace is described in detail in
Section 3.6. Sample workspaces for each supported toolchain are provided so that
you can familiarize yourself with STVD7 (for a listing of sample workspaces, see
Table 1).

Each workspace is comprised of three information sets: the project settings, the
visual environment and debugging information.

• The project settings consists of the information necessary for a successful
build of an application (commands to run, makefile file etc....). Your
workspace’s project settings include the definition of your application toolchain
(see Section 3.5).

• The debugging information includes information on breakpoints, memory
mapping, advanced breakpoints programs, trace etc..

• The visual environment consists of the open windows elements, along with
their current layout, customized toolbars and menus. The visual environment is
composed of two environments, one in the Build context and one in the
Debug context (see Section 3.12).

The above workspace information is stored in three types of files: a workspace file
(*.wsp) and two auxiliary files (*.wed and *.wdb).

Both project settings and debugging information is stored in the same workspace
file (*.wsp). In addition, to allow you to use the same workspace file for any STVD7
version (such as the STVD7 Simulator version, STVD7 for HDS2 Emulator, STVD7
for DVP, and/or STVD7 for EMU3 Emulator), the project settings and debug
information (such as the toolchain used, MCU emulated, memory mapping, etc.)
are kept separately in the same *.wsp file for each STVD7 version.This allows you
to use the same workspace file to debug the same application for two different
MCUs or MCU configurations on different STVD7 versions.
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Visual environment information (such as the location of debug windows, the
appearance of toolbars, and other aspects of STVD7’s graphical interface) is
saved in separate files for each of the two contexts of STVD7.  Graphical interface
preferences while in Build context are saved in a *.wed file, and graphical
interface preferences while in Debug context are saved in a *.wdb file.  Each of
these files is attached to a given workspace.  

Note that if you move a workspace file (for example, mywork.wsp) to a new folder,
take care to move the associated *.wed and *.wdb files (mywork.wed and
mywork.wdb) with the workspace file in order to preserve the latest visual
environment of your STVD7 session.

3.5 Toolchains and application files

A quick summary of development toolchains and application file types supported
by STVD7 will help you in setting up your workspace.

Three different development toolchains are currently supported by the STVD7.
Each type of toolchain has its own application and executable file types, project
environment and building tools (i.e. linkers and convertors):

• The ST7 macroassembler toolchain from STMicroelectronics, which
generates either .s19 or .hex executable files with various intermediate files,
such as  .map or .lst files.

• The Hiware C or Assembler toolchain, which generates .abs executable
files with various intermediate files, such as .o or .dbg files.

• The Cosmic C or Assembler toolchain which generates .elf executable
files with various intermediate files, such as .o or .st7 files.

When you set up a workspace, you will need to define the following project
settings:

• The toolchain to be used—Hiware, Cosmic or ST7 macroassembler.

• The executable file (*.abs, *.elf, *.s19 or *.hex depending on
toolchain—refer to Table 2).

• The maker program for the toolchain. The maker program can be a part of the
toolchain software (such as Hiware’s maker.exe) or you can choose to use a
generic maker such as Nmake.exe or Gmake.exe (which is provided with the
STVD7).

• The maker batch file (*.mak or *.bat). This is a file which you create for
each application which spawns the compilation and/or link step each time you
wish to build or rebuild. In it, you define the conditions for recompiling, re-



3 - STVD7 ST7MDTU5-EMU2B User Manual

26/71

linking or both.
Default *.mak or *.bat files are often included with the toolchains—for
example, maker.mak is included with the Hiware toolchain and simply
recompiles your application if it detects that the file has been saved since the
start of your debugging session. The STVD7 software includes sample *.mak
and/or *.bat files for each toolchain—these are listed in Table 1.

3.5.1 About executable files

The user should verify that the options to include debug information were active
during creation of the project files. Table 2 summarizes the way each toolchain
functions and lists the different file types (source files, intermediate files and
executable files) used and produced by the toolchain. The executable file types

Table 1: Sample files included with STVD7

Toolchain
Sample Workspace (with 

default path
Sample Make and/or Batch 

files (with default path1)

1) The full default path is: C:/Program Files/Stm/st7toolchain/stvd7/
hds/sample/...

Description of 
Make/Batch File

ST Macro 
assembler

.../realtim/realtim.wsp .../realtim/tim_rtc.bat Batch file that 
forces a recompile 
of the application.

.../spim11/spim11.wsp .../spim11/spim11.bat Batch file that 
forces a recompile 
of the application.

Cosmic

.../c/cosmic/sample.wsp .../c/cosmic/sample.mak Recompiles only if 
one (or more) of 
the application files 
has been resaved.

.../c/cosmic/sample.bat Batch file that 
forces a recompile 
of the application.

Hiware .../c/hiware/sample.wsp

.../c/hiware/build.mak Recompiles only if 
one (or more) of 
the application files 
has been resaved.

.../c/hiware/rebuild.mak Forces a recom-
pile of the applica-
tion.
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and intermediate file types necessary to exploit fully the STVD7 capabilities are
listed.

The executable file(s), source files and any necessary intermediate files (these
are listed above and contain debug information necessary to the STVD) should be
located in the same project directory. You do this when you define your workspace.

Note: It is always preferable to have access to all of the files generated by the development
toolchain. However, you can load *.s19 or *.hex binary files directly and have limited
debugging capabilities (refer to Section 3.8).

Table 2: Toolchain steps and their output files

Toolchain: ST Macroassembler Hiware Cosmic

Compile or Assemble Step:

Source File 
Types

.asm .c, .asm .c, .s

Required 
Options

asm -li macrost7.asm <NONE> +debug

Resulting File 
Types

.obj, .lst .o, .dbg .o

Linker Step:

Required 
Options

lyn macrost7.obj, macrost7

asm macrost7.asm  -sym -fi=macrost7.map

<NONE> <NONE>

Resulting File 
Types

.map, .lst .abs .st7

Converter 
Step:

obsend macrost7, f, macrost7.s19, srec

or

obsend macrost7, f, macrost7.hex, intel

not
applicable

cvdwarf

Resulting 
executable 
file:

.s19 or .hex .abs, 
.elf

.elf

Necessary 
Intermediate 
Files:

.map, .lst .o, .dbg <NONE>
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3.6 Creating a workspace

1 Select File>New Workspace. This command opens the New Workspace
window where you define the name of your workspace and the directory in
which you want to work.

Figure 10: New Workspace window
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2 Then, click Next>. The New Workspace: Project Settings dialog box
appears:

Here you enter your software toolchain, your executable filename and your
build parameters either by typing or using the drop boxes.

3 Select the toolchain and enter the name of your application’s executable file.
For example, if you wish to use the Hiware toolchain for ST7, your executable

file will be of type *.abs (refer to Table 2)—click on the browse button  to

browse to the folder where your executable file is saved and select it.

4 Next, choose the type of maker your application uses from the drop down list. In
the example above, we have chosen the default Hiware maker, maker.exe.
STVD7 will automatically look for this maker file in the folder you defined as the
Hiware toolchain path. 

Figure 11: New workspace project settings
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5 Finally, you must define a make file or a batch file. There are several sample
files provided with STVD7 (see Table 1). Here we have chosen build.mak as
the default make file, used when the Build command is issued, and
rebuild.mak as the make file to use when the Rebuild command is issued. 

6 After you have finished defining your project settings, click Finish.

Once the workspace is opened, the Workspace window displays its contents.

When you create a new workspace, the first time you switch to Debug context (see
Section 3.12 for an explanation of STVD7 contexts), the MCU Configuration
window will automatically open to prompt you to choose you target MCU and
confirm or modify its option and memory configuration (see Section 3.13).

3.7 Opening an existing workspace

If you have already created a workspace, you simply need to open it in order to
load all of your project settings into the STVD7.

Note: There are a number of sample workspaces provided with STVD7 that you can open to get
familiar with STVD7. These samples are listed in Table 1.

1 From the main menu, select File>Open Workspace.
This command opens a window where you can browse to any folder you wish,
and select an existing workspace.

Figure 12: Open Workspace window
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2 The Workspace window opens.

When a workspace is opened, all of the predefined project settings are loaded
into the STVD7. The Workspace window will show a structured representation
of the project. For example, mywork.wsp shows that it uses build.mak as
the make file and sample.abs as the executable file.

Note: Although the name of the executable file is shown in the Workspace window, it has not yet
been loaded into the emulation memory.

Figure 13: Workspace window
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If you click on the Source Directory tab, the window will show every source
and intermediate file type (*.c, *.s, *.asm, *.h or *.o) in the selected
directory.

3 If there are no source files shown in the Source Directory tab of the Workspace
window, or you wish to list additional files stored in another folder, you may
browse to them by clicking the Double Click here... folder. The Add Source
Directory window pops up allowing you to enter or browse for a new directory,
and filter out the file types of interest. You may also choose to specify a

Figure 14: Source Directories tab
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directory that is relative to the workspace directory by clicking on the Path
relative to the Workspace directory option.

4 To load the executable file, as well as any intermediate files, click the Debug

icon or the Reset Chip icon . The application and symbols will be
loaded. Before you can start debugging, you must set the target hardware
device by configuring the MCU.

3.8 Opening files directly for debugging (*.abs, *.s19, *.hex  and *.elf )

You may also load .abs, .elf, .s19 and .hex files for debugging directly
using the Open Workspace command, without having to enter build parameters
immediately. (You may always enter the build parameters at a later time by
selecting Project>Project Settings from the main menu to open the Project
Settings dialog box.)

Note: However, for .s19 and .hex files to open correctly, the *.map and *.lst files generated by
the ST7 toolchain during compilation must also be present.  If this is not the case, refer to
Section 3.9.

Figure 15: Add source directory
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The range of debugging features available will be more limited because the source
files will not be accessible.

1 Launch STVD7 and select File>Open Workspace from the main menu. 

2 Browse to the folder where your binary file is stored, and select ST7
Application files (*.abs, *.s19, *.hex, *.elf) in the Files of type field. 

3 Select your binary file (*.abs, *.s19, *.hex or *.elf) and click Open.

3.9 Opening lone programmable files (*.s19 or *.hex)

If you do not have access to the *.map and *.lst files generated by the ST7
toolchain, you may also load isolated *.s19 and *.hex files from within STVD7.

The range of debugging features available when you open these files will be very
restricted. You will only have access to the Disassembly Window and the
Memory window.

1 Launch STVD7 and select Debug>Start Debugging from the main menu or

click on .

2 Open the Memory window by selecting View>Start Debugging from the main

menu.

3 With the cursor in the Memory window, right-click the mouse to open the
Memory contextual menu.

Figure 16: Open Workspace window
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4 In the Memory contextual memory, select File>Restore Layout. The Load File
to Memory window opens.

5 Browse to the folder where your programmable file is stored, and select either
the Motorola format (*.s19) or the Intel format (*.hex) in the Files of type field. 

6 Select your programmable file (*.hex or *.s19) and click Open.

The binary code in the .s19 or .hex file will be loaded into STVD7 and you will be
able to access the Disassembly window and the Memory window. A workspace file
(of the same name as the programmable file, but with an extension .wsp) will be
created automatically.

3.10 Changing your project settings

The Project menu contains the Build and Rebuild All commands you need to
recompile your application after having made changes to it in the course of

Figure 17: Load File to Memory
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debugging. You may also access your project or toolchain settings in the event you
wish to change them.

From the main menu, select Project>Project Settings. 

Figure 18: Project menu

Figure 19: Project Settings window
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You can change your settings here and continue running your application. When
you exit STVD7, the system will ask you if you want to save these settings in the
workspace you have been working in. If you choose yes, these will become your
new workspace settings; if you choose no, these settings will be lost.

The Toolchain Path... item invokes the following window:

In this window, you can define your builder and/or Assembler paths. Clicking 
opens a browser window.

3.11 Saving workspaces

Whenever the current workspace is closed, it is automatically saved. This can
happen either when exiting STVD or opening or creating a new workspace.

In addition to this, a workspace can be explicitly saved with the File>Save
Workspace... or File>Save Workspace as... commands.

The user is given the choice of which of the workspace elements to include in the
saved file. Either the visual environment or the debugging information may be
saved alone, or both may be saved together. This is configured as follows:

1 From the main menu, select Tools>Options.

2 In the Options window that opens (see Figure 21), select the Workspace tab. 

Figure 20: Toolchain paths
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3 Choose whether you wish your saved workspace to include either the visual
environment or the debugging information or both.

4 Select which windows will appear docked when a project is opened by checking
the appropriate check boxes in the Floating windows in the main frame area.
Only windows currently docked in the main window can be included.

5 Click Apply to confirm your settings.

6 Click OK close the dialog box.

In addition, open file contexts and current window positions are saved when the
workspace is closed. This feature restores the workspace window, window layout
and file views to that which was current when STVD7 was closed. The toolbar
layout, plus customized toolbar content is also saved and restored with the
workspace (options set via the tabs entitled Toolbars and Commands).

By default (i.e. when saved automatically) the workspace is saved as file
<application>.wsp. The name of the file corresponds to the name used for the
executable file (for example, <application>.abs for a Hiware executable file).

Figure 21: Workpace tab of Options window
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Note: Using the Configuration Setup dialog box (available from the MCU Configuration dialog
box), you can also control what type of MCU configuration information is restored from a
workspace file (*.wsp).

3.12 Debug context and Build context

There are two STVD7 contexts, the build context and the debug context. Until
now, in creating a workspace, and defining your project settings, you have been in
the build context. To proceed step—configuring your MCU—you need to change to
the debug context. 

Briefly, the two contexts are different in that:

• In the build context, you can open and close workspaces and build or re-build
the application executable file. 

• In the debug context you set the emulated MCU configuration (this step is
described in Section 3.13) and debug the executable file created while in the
build context.

3.12.1 Build Context

The build context is the context set when starting STVD7. In this context, it is not
necessary to be connected to an emulator and the debug commands are not
available. You can also edit the source files of an application and perform the use
the Build command to perform compile and link actions in an interactive and
iterative way to re-build the application executable file. 

3.12.2 Debug Context

In this context, the following debug actions can be carried out:

• Loading, running and stopping the application.

• Defining the MCU configuration (MCU options and memory mapping).

• Viewing source and disassembled code.

• Setting instruction breakpoints with a counter and/or condition.

• Setting data breakpoints.

• Viewing local variables, memory and ST7 registers.

• Viewing history of execution from the trace buffer or with the Call Stack feature
analyzing the performance of a piece of code.
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3.12.3 Switching between contexts

The switch between contexts usually occurs when the Start Debugging and Stop
Debugging commands are used.

From the main menu, choose Debug>Start Debugging or Stop Debugging or
click on the Start Debugging or Stop Debugging icons shown in Chapter 3.

While debugging, the editor allows source files to be modified. To switch to the
Build context perform either a Build or Rebuild action or use the Stop Debugging

3.13 Configuring the MCU

After you create or open a workspace, the next step you must perform before
starting your STVD7 debugging session is to define and configure the target device
(MCU) that you wish to emulate.

The target device is defined and configured from the MCU Configuration window.

1 First, ensure that you are in Debug context by clicking on . (STVD7 has
two contexts: Debug context and Build context—these are described in
Section 3.12.)

Note: The first time you enter into the Debug context after having created a new workspace, the
MCU Configuration window will be opened automatically.

2 Select Tools>MCU Configuration from the main menu. The MCU
Configuration window will open.

Figure 22: Start Debugging and Stop Debugging icons
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An example of a typical MCU Configuration window is shown in Chapter 3. 

Note: The options shown in the above example may not be available for your particular target MCU.

3 Set the Target MCU. In the MCU name field, select the target device for which
the application is intended from the dropdown box. Once a target MCU has
been chosen, the Option configuration and the Memory configuration fields will
show the default values for this device.

4 Configure the MCU Options and On-Chip Peripherals. All of the
configurable options on your target hardware device are listed in the Option
configuration fields. Beside each option, a default value is given. You may
change this value by clicking on it and choosing a new value from the drop
down list.   This allows you to configure your target device’s options and on-chip
peripherals. Depending on the MCU selected, the default settings in the Option
configuration fields will change. It is up to you to configure those options that will
impact your application so that the emulator accurately emulates your target
device.

Note: For more information about the configurable options available on your target hardware
device, please consult your target MCU’s datasheet.

Figure 23: MCU Configuration window
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5 Configuring the MCU Memory. The default memory settings depend on the
MCU selected. However, you can configure the memory settings as you wish if
your application requires non-default settings. This feature would enable you,
for instance, to temporarily increase the ROM size during the development
phase of your application.

There are two methods for configuring the memory settings on the MCU: by
typing in the start and stop addresses of each memory zone into the memory
configuration window, and by graphically moving the memory zone
boundaries in the graphic memory configuration viewer (see page 43 for
more instruction).

Memory zone types
The left column of the memory configuration window indicates the address
range of each memory zone. The right column indicates the memory type of each
zone. Depending on your target MCU, the available memory types may be:
Peripherals, RAM, ROM, Stack, System, EEPROM, Reserved, Vectors,

Figure 24: Memory mapping
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Application. Some of these zones can have their type and size modified, others
cannot be modified. Their definitions and properties are explained as follows:

• Peripherals: Microcontroller internal or rebuilt peripherals registers. Their
properties are defined as in the microcontroller datasheet. This memory
cannot be modified.

• RAM: Random-Access-Memory of the microcontroller. This memory type can
be modified.

• ROM: Read-Only Memory of the microcontroller. Write protected. This memory
type can be modified.

• Stack: Stack of the microcontroller. This memory type cannot be modified.

• System: The emulator uses this space for emulation management. This
memory type cannot be modified.

• EEPROM: This memory is internal to the microcontroller and is located inside
the emulation device. The programming of this zone is done according to an
automaton found in the datasheet. This memory type cannot be modified.

• Reserved: This memory zone is reserved as on the microcontroller. It is not
allocated to any use and is write protected. This memory type cannot be
modified.

• Vectors: This memory zone contains the user interrupt vectors zone. It is write
protected. This memory type can be modified.

• Application: This memory type is microcontroller-specific. The user can add
memory or peripheral resources on its hardware. It is not available on every
emulator. Properties are linked to the user hardware. This memory type can be
modified.

For most target MCUs, you may modify the following types of memory zone: RAM,
ROM, Reserved and Application. This feature would enable you, for instance, to
temporarily decrease the RAM zone, increase the size of the ROM (to exceed what
is available on the real microcontroller) during the first stages of development.
Once your program is functional, you can start to optimize its size by reducing your
code and returning these zones to their original size. There are two different
actions you may perform on the memory configuration: 

• change the type of an entire existing zone.

• define a new zone of any type wherever possible.

To change an existing memory zone: 
1 Select the memory zone to be modified.



3 - STVD7 ST7MDTU5-EMU2B User Manual

44/71

2 Click on the Modify button at the bottom of the window. A New MCU Memory
Range dialog box will open, allowing you to change either the address range
and/or the memory type of the memory zone.

To create a new zone of any type:
1 Click on the Insert button. The New MCU Memory Range dialog box will

appear. 

2 Enter the address range of the new memory zone in the From and To fields.

3 Select the type of the new memory zone in the Type field.

4 Click OK to validate your choice. 

The new memory zone will then appear in the MCU Configuration window unless
you tried to create a new zone in a non-modifiable memory space (such as Stack
or EEPROM).

To use the Graphic Memory Configuration viewer:
1 In the memory configuration window, click on the zone whose boundaries you

wish to move.

2 Check the Selection auto zoom box in the upper right-hand corner. The
graphical view of the memory configuration will be scaled so that the zone you
have selected is easily visible.

3 At the upper and lower boundary of the zone, at the left-hand side of the
graphical viewer, you will see a small triangle and rectangular box giving the
boundary addresses of the memory zone. You can change a boundary address
by dragging and dropping the triangle with the mouse to its new location. The
triangle can be moved either up or down, left or right in the graphical viewer.

Figure 25: New MCU memory range
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The MCU configuration that you specify will, by default, be saved in a workspace
file (*.wsp) for the project. The next time the application is opened, the STVD will
automatically set the MCU configuration (as well as the layout of opened windows
and other debug information) to the same conditions you had when you left the last
debugging session.

If you do not wish your MCU configuration information to be saved in the
workspace file, you must alter the default Configuration Setup options by clicking
on the Conf... button.

3.14 Start debugging!

Once in debug context, you are now ready to start debugging your application
using the emulator.Full documentation on how to:

• control your STVD7 work environment

• use its integrated editor

• use the many debugging windows and features

is available from the online help and the online STVD7 user manual, located under
Help in the main menu.
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4 EMULATOR FEATURES

4.1 Main features of the ST7 HDS2 emulator series

The features described below are common to all ST7 HDS2 emulators:

• Real-time emulation capability (internal frequency from internal 0.5 MHz up to
8 MHz).

• Full memory emulation (up to 64 KB).

• Real-time trace with 3 event conditions allowing selective recording.

• Hardware breakpoint capability on instruction Fetch.

• Hardware breakpoint capability on address.

• Breakpoint capability on invalid address access.

• Breakpoint capability if trace is full.

• 1K x 32-bit real-time trace (address, data, ctrl).

• 6 different modes to configure trace access by combining 3 event conditions.

• Selective trace recording capability.

• 2-Trigger output capability.

• Can use as an external clock source either the on-probe oscillator, or an
external source via the front panel input.

• 4 probe inputs to display application signals in the trace. 

4.2 Specific features

The features described below are specific to the ST7MDTU5-Active Probe:

• 12 MHz internal clock operation.

• The application power supply follower allows this emulator to run with
application VCC from 2.4 V to 5.5 V. When the probe is not connected to an

application board or if the application board isn't powered (application
VCC<2.4 V), the VCC default value is 2.4 V.

• All I/O pins of the ST7265 MCU and its sub-family are directly interconnected
to the user application board. No buffers or protective devices are inserted on
the probe.

4
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4.3 Emulator architecture

The ST7MDTU5-EMU2B emulator is composed of 2 parts:

The ST7 HDS2 (Hardware Development System) contains all of the common
resources necessary to emulate any ST7 device (such as memory and the link
interfaces with the PC). This board is connected to the PC via a parallel link and
to the second part by two 50-pin connectors.

The ST7MDTU5-Active Probe contains the specific resources necessary to
emulate the ST7265x family of MCUs, and is used as a link between the
ST7 HDS2 and your application.

4.3.1 ST7 HDS2 hardware

The hardware functions provided by this component are listed below:

• HDS2 CPU: Used to control the ST7XXX-HDS board and manage common
HDS2 features such as the parallel link with the PC.

• RAM memory:

- 64K bytes for ROM and RAM emulation.

- 64K bytes as break points control and Mapping.

- 1K x 32-bit as trace memory.

ST7MDTU5-EMU2B

PC Parallel Link Emulation Memory
Control RAM

Trace Memory
ST9 MCU

ST7 HDS2 Flat Cables

Address bus
Data bus

Control bus

Generic 
Probe

Emulation Chip
Socket

ST7MDTU5-TEB

Socket Adapter

Application
Board
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• Hardware breakpoint control logic to manage breakpoints from the 16-bit
address bus.

• Logical analyser control logic to manage sophisticated recording and
break events in the trace.

• PC link: parallel interface for communication with PC.

• ST7MDTU5-Active Probe interface—3 buses connect the ST7 HDS2 to
the ST7MDTU5-Active Probe:

- Address bus (16-bit) of the ST7 emulation chip used for RAM
addressing and trace.

- DATA bus (8-bit) of the ST7 emulation chip.

- Control bus to manage ST7MDTU5-Active Probe hardware-like
breakpoint features.

4.3.2 ST7MDTU5-Active Probe hardware

The ST7MDTU5-Active Probe is made up of two probe components—a ST7
Generic Probe and a ST7MDTU5 Target Emulation Board (TEB) included in the
emulator kit. See Step 3: Connecting the probe to your application board on
page 17 for more details. 
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The hardware functions provided by the ST7MDTU5-Active Probe are:

• Probe Emulation MCU: This is an ST7 microcontroller similar to those of the
emulated target device(s), which runs in emulation mode. It acts as the ST7
core and gives access to all on-chip peripherals.

• Control logic: Control logic is provided to manage the software execution by
the user (i.e. program running and halting).

• Application VCC follower: The probe emulation MCU is supplied with the

same voltage as the application (i.e. must be in the range 2.4 V to 5.5 V).

• ST7 HDS2 interface: All of the communication buses connecting the active
probe to the ST7 HDS2 board are buffered:

- ST7 Address bus (16-bit) of the ST7265 in emulation mode.

- Data bus (8-bit) of the ST7265 in emulation mode.

- ST7 emulation chip control bus for trace recording, breakpoints and
memory mapping.
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4.4 Output triggers

Your ST7 HDS2 emulator has two output triggers, OUT1 and OUT2. The OUT1
and OUT2 outlets are available via SUB-click connectors located on the front panel
of the ST7 HDS2 emulator box.

You can program the output signals to these triggers using ST7 Visual Debug:

1 From the main menu in ST7 Visual Debug, select View>Hardware Events.
The Hardware Events window will open in your workspace.

Figure 26: Trigger outputs

OUT1 Trigger output OUT2 Trigger output

Triggers

Analyser
ProbeST7 HDS2 Emulator
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2 Right-click the mouse while the mouse pointer is anywhere in the Hardware
Events window.

3 Choose New Hardware Event from the contextual menu. The Hardware event
settings dialog box will open as below.

4 Choose the trigger output that you wish the signal to be sent to (i.e. OUT1 or
OUT2) and check the Enabled box.

5 You may trigger output signals by setting an event on any of the following:

• a whole variable—creating an event for synchronization, which enables you to
preset the pulse synchronization for external equipment connected to the
output trigger.

• a single address—also creates an event for synchronization (see above).

• a range of addresses—creating an event to measure time, which enables you
to measure the time elapsed during a subroutine execution.

A positive impulse is emitted on OUT1 and OUT2 when a specific condition is met.
This impulse lasts for one Clock cycle.
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4.5 Analyser probe input signals

The ST7 HDS2 allows you to use 4 external input signals (TTL level). These
signals are on pins 6,7,8,9 of the Analyser Probe connector located on the front
panel of the emulator as shown below.You can view these probe inputs using ST7
Visual Debug. From the main menu, select View>Trace. The input signal values
are listed under the Sig column (AL3..0).

ST7 Visual Debug’s Logical Analyser allows you to use these input signals to
define trace filtering or output trigger events. From the main menu, select
Tools>Logical Analyser to open the dialog box. A full description of how to use
this facility to control trace recording or trigger output signals is given in the ST7
Visual Debug online help. 

A rainbow-colored cable will also be delivered to connect your application to these
inlets. Each red connector is to be connected to your signal. Each black connector
is to be connected to the reference ground for the signal.

Colors are attributed as follows:

• AL0 is to be taken between the RED (signal) and BROWN (ground) wires

• AL1 is to be taken between the YELLOW (signal) and ORANGE (ground)
wires.

• AL2 is to be taken between the BLUE (signal) and GREEN (ground) wires.

• AL3 is to be taken between the GREY (signal) and PURPLE (ground) wires.

Figure 27: Analyser probe connector
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4.6 Front panel LEDs

Four LEDs on the front panel of the HDS2 box indicate the state of the
development tool during emulation:

• Power (Green)—indicates that the 5 V power supply is ON.

• Run (Yellow)—indicates that the ST7 is running (not in RESET, WFI and HALT
mode).

• System (Red)—not used with this emulator.

• Reset (Red)—not used with this emulator. 

Figure 28: Front panel of HDS2 emulator
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4.7 On-chip peripherals

You can configure certain on-chip peripherals in ST7 Visual Debug’s MCU
Configuration dialog box (refer to Section 3.6: Creating a workspace on page 28)
so that the emulator accurately emulates your target device.

The on-chip peripheral options supported by the emulator are:

Fosc

The emulator supports only the 12 MHz Fosc value that is generated by the
emulator clock source.

4.8 Emulation functional limitations and discrepancies

Power supply
The application supply follower allows this emulator to run with an application VDD

ranging between 2.4 V to 5.5 V. If the application isn't powered, or the VDD < 2.4 V,
the power supply is maintained at 2.4 V. If your application is powered by a voltage
greater than 5.5 V, the emulator will limit this value internally to 5.5 V.

Low voltage detector management
The Low Voltage Detector is not yet available on this emulator release.

Option byte configuration
Some features of MDTU5 emulator are configurable under Option byte control. It is
possible to modify those features with from the MCU Configuration window. The
table below summarizes all of the configurations possible:

Note: USBEN option bit is not configurable in emulation mode (USBEN alternate function is always
enabled on Port F4).

Name Configuration Description

WATCHDOG Soft
Hard

Watchdog activated by software 
Watchdog alway active

PS_MODE DUAL_MODE
STAND_ALONE
USB_MODE

Dual supply mode (normal)
Stand-alone mode forced
USB mode forced

PE5PU PULL-UP ON
PULL-UP OFF

Determines if a pull-up is con-
nected on Port E5
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APPENDIX A: EMC CONFORMITY AND SAFETY REQUIREMENTS

This emulator respects the EMC requirements of the European guideline 89/336/
EEC under the following conditions:

• Any tester, equipment, or tool used at any production step or for any
manipulation of semi-conductor devices must have its shield connected to
ground.

• All ferrites provided with the emulator kit must be attached as described in the
hardware installation instructions of the relevant user manual(s).

• Your emulator must be placed on a conductive table top, made of steel or clean
aluminum, grounded through a ground cable. 
All manipulation of finished goods must be made at such a grounded
worktable.

• The worktable must be free of all non-antistatic plastic objects.

• It is recommended that you wear an antistatic wrist or ankle strap, connected to
the antistatic floor covering or to the grounded equipment. 

• If no antistatic wrist or ankle strap is worn, before each manipulation of the
powered-on emulator, you must touch the surface of the grounded worktable.

• It is recommended that antistatic gloves or finger coats be worn.

• It is recommended that nylon clothing be avoided while performing any
manipulation of parts.
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APPENDIX B: TROUBLESHOOTING

B.1 Identifying the problem

B.2 Changing the parallel port setup on your PC

Under certain circumstances, you may receive the following error message:

"Connection Error (LPT1/LPT2): Interconnection failure. Verify your
input/output cable."

This may mean that the setup of the LPT1 or LPT2 port on your PC is not
compatible with the ST7MDTU5-EMU2B.

IF THE FOLLOWING OCCURS: THEN...

Error Message (when starting the 
STVD7 for HDS Emulator):
“No message received from 
emulator.”

Ensure that:

• The parallel cable is connected between the
emulator and one of the PC’s parallel ports (LPT1 or
LPT2). Note that the use of switch boxes between
the parallel port connector of your PC and the
emulator are not recommended.

• The development board is powered on.
• The parallel cable used is the one supplied with the

kit by STMicroelectronics.

If none of the above items has been overlooked, this 
may mean that your parallel port connection needs to 
be reconfigured. 

Please refer to Section B.2: Changing the parallel port 
setup on your PC on page 59.

Error Messages (when starting 
the STVD7 for HDS Emulator):
"Communication error with 
EMULATOR board.”

or

“SYSTEM ERROR DETECTED 
by EMULATOR BOARD: RESET 
CPU.” 

Ensure that:

• The flat cables linking the ST77MDT00-Active Probe
and the emulator box are properly connected.

• The selected configuration file matches the
connected ST77MDTU5-Active Probe configuration.
If it doesn’t, from within ST7 Visual Debug, open the
MCU Configuration dialog box by selecting
Tools>MCU Configuration from the main menu. 
Choose the correct MCU target device in the
dropdown list, then click OK to save your changes to
the *.wsp file for your debugging session. Exit
STVD7 and power off the emulator. Power on the
emulator and restart STVD7 to ensure correct
installation.
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To set up the port correctly:

1 Shut down and restart your PC in order to enter the BIOS setup.

2 Follow the messages displayed on the screen and when prompted, press the
key required to enter the BIOS setup (usually a function key or the ESC key).

3 Select the parallel ports menu. (This may be listed under I/O ports.)

4 Change the Mode of the LPT port that you have connected the development
board to (i.e. either LPT1 or LPT2) to one of the following compatible modes,

according to the following table:

5 Save your changes and exit the BIOS setup.

B.3 Running the hardware test

The Hardware Test in ST7 Visual Debug lets you check that your emulator is
correctly connected, configured and working. You can test components of the
development board individually, or all at the same time.

If problems occur during debugging (such as bad debugger responses and
unexpected behavior), you should check for hardware problems using the
Hardware Test function, and if any are detected, contact your STMicroelectronics
sales representative (see Product Support on page 65).

You may open the Hardware Test dialog box by:

• selecting, from the Main Menu, Emulator>Hardware Test

• clicking on the Hardware Test icon in the Emulator toolbar.

Warning: Be cautious in performing a Hardware Test on the emulator while an application is
open. The opened application WILL BE corrupted by the hardware testing process. If
you find that your application has been corrupted, simply close the application, and
reopen it.

Operating System Compatible Parallel Port Modes

Windows 95

Windows 98

Windows NT4

Windows 2000

Bidirectional or Centronics (Nibble)
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The Hardware Test
dialog box shows a list
of different tests that
can be performed on
the emulator.

Check the box of each
test that you wish to
perform (they are all
checked by default)
and click Apply to
start the hardware
test.

The Hardware tests
will be performed one
by one, and the results
summarized in the
dialog box as shown
on the right:
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APPENDIX C: GLOSSARY

Application Board

This is the printed circuit board onto which you wish to connect the target ST7
MCU. It should include a socket or footprint so that you can connect the application
board to your emulator or development kit using the probe and the appropriate
device adapter. This allows you to emulate the behavior of the ST7 MCU in a real
application in order to debug your application program.

Device Adapter

Device adapters are included in your emulator kit to allow you to connect the
emulator to your application board. The type of device adapter depends on the
target device’s packaging. Many MCUs come in more than one different package,
and you should therefore use the device adapter that corresponds to the type of
package you have chosen for your application.

ECP

Extended capabilities port communication standard.

EPP

Enhanced parallel port communication standard.

MCU

Microcontroller Unit. Otherwise referred to as the “target device” throughout this
manual. This is the core product (or family of products) for which the Development
Kit is designed to act as an emulator and programming tool. In general terms, an
MCU is a complete computer system, including a CPU, memory, a clock oscillator
and I/O on a single integrated circuit.

ST7MDTU5-Active Probe

A printed card having connector pins that allow you to connect the Emulator to the
MCU socket of the user application board. Using the active probe allows the HDS2
emulator to function as if it were the target device embedded in your application.
The probe is connected to the emulator by two flat cables.

RC network

Resistor-capacitor network.
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ST7 Visual Debug (STVD7)

A graphic debugger software package that allows you to debug applications
destined for the ST7 family of MCUs, either using a built-in simulator function, a
Development Kit or an HDS2 Emulator.

Target Device

This is the ST7 MCU that you wish to use in your application, and which your
emulator or development kit will emulate for you.

TEB

Target Emulation Board. This is the interface between the emulator and the
application board. It is directly plugged into the HDS2 Generic Probe and
connected to the application board via an adapter.

User Application Board

Designates your application board. 
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PRODUCT SUPPORT

If you experience any problems with this product or if you need spare parts or
repair, contact the distributor or ST sales office where you purchased the product.

Getting prepared before you call

Collect the following information about the product before contacting ST or your
distributor:

1 Name of the company where you purchased the emulator kit.

2 Date of purchase.

3 Order Code: Refer to the side of your emulator kit box. The order code will
depend on the region for which it was ordered (i.e. the UK, Continental Europe
or the USA).

4 Serial Number: The serial number is located on the rear panel of the emulator
box.

5 Target Device: The sales type of the microcontroller you are using in your
development.

Contact list

Note: For American and Canadian customers seeking technical support the US/Canada is split
in 3 territories. According to your area, contact the following sales office and ask to be
transferred to an 8-bit microcontroller Field Applications Engineer (FAE).

Canada and East Coast

STMicroelectronics
Lexington Corporate Center
10 Maguire Road, Building 1, 3rd floor
Lexington, MA 02421
Phone: 781-402-2650

Mid West

STMicroelectronics
1300 East Woodfield Road, Suite 410
Schaumburg, IL 60173
Phone: 847-585-3000
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West coast

STMicroelectronics, Inc.
28202 Cabot Road
Suite 650
Laguna Niguel, CA
Phone: (949) 347-0717

Europe

France (33-1) 47407575
Germany (49-89) 460060
U.K. (44-1628) 890800

Asia/Pacific Region

Japan (81-3) 3280-4120
Hong-Kong (852) 2861 5700
Sydney (61-2) 9580 3811
Taipei (886-2) 2378-8088

Software updates

You can get software updates from the ST Internet web site http://mcu.st.com.
For information on firmware and hardware revisions, call your distributor or ST
using the contact list given above.

Hardware spare parts

Most of the hardware you will require is included in the emulator kit. However,
some special applications may require additional parts, such as connecting an
external clock, or you may need additional sockets for your application board.

Below is a list of manufacturers and dealers of SMB and BNC connectors that can
be used with our product.

European manufacturer Radiall
and product references: For worldwide sales locations,

visit Radiall’s website at:
www.radiall.com

The EXTERNAL clock male connector on the emulation probe has the
following commercial reference:

- In SMB range: Ref.: 114665.
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Adaptable Female connectors that fit this connector are:

- SMB upright range
Ref.: 114005 for cable 2,6.
Ref.: 114003 for cable 4,2.
Ref.: 114009 for cable 3,8.

- SMB kneed range
Ref.: 114165 for cable 2,6.
Ref.: 114163 for cable 4,2.

- SMB to BNC range
Ref.: 191214. Adapter SMB female / BNC male.
Ref.: 191215. Adapter SMB female/ BNC female.

USA manufacturer R-Tek
and product references 411 Quentin Road

Palatine, IL 60067
Phone: (847) 934-7900
Fax: (847) 934-7946

Adaptable female connector part numbers:

- CCAX00168-2: cable length 2 ft, with SMB plug to BNC plug.

- CCAX00168-3: cable length 3 ft, with SMB plug to BNC plug.

Yamaichi sockets
You can order additional Yamaichi QFP sockets directly from Yamaichi at:

http://www.yamaichi.de/Pu/quad_flat_pack/spec/a21-ic149.htm
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